Welcome to the Leukemia & Lymphoma Society Urgent Need Program secure on-line

Care Team Registration and Application Portal!

LLS, in partnership with Moppie's Love, established the Urgent Need Program to help patients with acute financial need. The program helps families who are coping with pediatric blood cancer or adult blood cancer patients enrolled in clinical trials by providing assistance for non-medical expenses including rent, mortgage, lodging, utilities, childcare, elder care, food, transportation, car repair, car insurance, phone service, and acute dental work related to treatment. Eligible Patients receive an annual one-time stipend of $500 for emergent costs that impede the patient from receiving timely treatment.

Eligibility Requirements

  • Pediatric (Birth to 19 years of age) and Young Adults (20 to 39 years of age) may qualify. Older Adults (39+ years of age) may qualify if they are enrolled or are enrolling in a clinical trial.
  • Have a household income that is at or below 500 percent of the U.S. federal poverty guidelines as adjusted by the Cost of Living Index (COLI).
  • Be a United States citizen or permanent resident of the U.S. or Puerto Rico
  • Have a blood cancer diagnosis confirmed by care team

For your convenience, the Care Team Application Portal will be available 24 hours a day.

Step 1: Register on the Portal

To Register : You must have a valid email address and a provider tax ID/NPI. Once you submit your registration, you'll receive an email (typically within five minutes) directing you to a website to create your password. You can then begin entering your application information.

Click Register, to begin the registration process.

Step 2: Submit an Application

To submit an application, please click Start.

If this is your first time on the portal, be sure to register first.

Adobe Reader 9 or newer is required in order to properly display the forms that you can download. Please ensure that you have it installed prior to downloading any forms from the LLS Patient Center.

The following web browsers have been tested and are known to work with this site:

  • Internet Explorer 8 or higher
  • Internet Explorer 11 is not supported
  • Google Chrome 30.0.15 or higher
  • Firefox 4.0
  • Adobe Reader 9 or higher version
  • File size uploads are limited to 2MB

Newer versions of these should work without any issues. Older versions of these, or browsers not listed here, may work. However, if you experience any problems, please use one of the browsers listed above. Each one is free, widely available, and often pre-installed on many computers.

Please note: Cookies must be enabled. Cookies are usually already enabled, but refer to your browser's help documents for instructions on how to enable cookies if they are disabled. If cookies are not enabled, you won't be able to log in, and will see the log-in page repeatedly.